AddFertileStorage in fabrication Plant

Added by Alderete Tommasi Francisco Martin almost 2 years ago

Hi, I'm Francisco Alderete, I'm currently doing an internship in the group of Reactor Physics of the LPSC Grenoble directed by Adrien Bidaud.

I intended to simulate a scenario in which a fabrication plant gets fissile products from the waste of a UOX PWR and the fertile products from a Storage with a big amount of Depleted Uranium. With those materials the fabrication plants creates fuel that is later used in a PWR MOX.

The problem is that every time that I try to use the function AddFertileStorage of the class FabricationPlant the simulator crashes in the exact year when the fabrication plant is supposed to start working.

I attach the source file for the scenario I tried to simulate and the error message I received.

Thanks for your atention!

Scenario6.cxx - Scenario I tried to simulate (8.56 KB)

Error Message.odt - Error message received (35.2 KB)


Replies (3)

RE: AddFertileStorage in fabrication Plant - Added by LENIAU Baptiste almost 2 years ago

Hi, Franciscon thx you for your well documented post which help me to identify the bug.

The bug comes from the way you declare your infinite U depleted storage.

You must add ONE isotopic vector containing all your isotopes like that the following example, futhermore the method AddToStock has to be called after gCLASS->Add(Stock)

//Storage for infinite U and Pu
Storage *Stock = new Storage(gCLASS->GetLog()); //Definition of the stock
Stock->SetName("Stock"); //Its name
gCLASS->Add(Stock); //Adding the stock to the Scenario
IsotopicVector InfiniteDepletedU;
InfiniteDepletedU.Add(92,238,0, 3e31 );
InfiniteDepletedU.Add(92,235,0, 3e31 );
Stock->AddToStock(InfiniteDepletedU);

The thing is when you do :

Stock->AddToStock(ZAI(92,238,0) *  3e31);
Stock->AddToStock(ZAI(92,235,0) * 0.04375* 3e31);

You add TWO isotopic vector to the Storage ! And when the simulator build the fuel it has to manage a ferile storage whith 2 isotopic vector with one of pur 235U !!

Thx you very much for your post . See ya

RE: AddFertileStorage in fabrication Plant - Added by Alderete Tommasi Francisco Martin over 1 year ago

Now I did what you suggested, but I still get an error message when I run CLASS_Exec that says Bad_alloc...
I think there might be a bug

RE: AddFertileStorage in fabrication Plant - Added by MOUGINOT Baptiste over 1 year ago

could you post your input file ?

the new one :)
thx :)

(1-3/3)