Project

General

Profile

Actions

Bug #1277

closed

Problem in tracker when creating indexes on the tasks table in the sqlite3 database

Added by Betoule Marc about 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
Engine
Start date:
01/27/2011
Due date:
% Done:

0%

Estimated time:

Description

This problem is really strange, maybe its just coincidence...
After creating indexes on the tasks table with
create index task_idx2 on tasks(queued_on);
create index task_idx1 on tasks(seg_id, status);
The tracker does not init and
Operational Error: cannot commit transaction - SQL statements in progress
is raised in segments_registration.
Dropping the index seems to solve the issue. The segments_registration routine does not touch the tasks table.

I'm setting the priority to low as the speed of the web interface is acceptable even without those indexes. This could become a performance bottleneck for big projects.

Actions #1

Updated by Le Jeune Maude almost 12 years ago

  • Status changed from New to Resolved

right now, the problem is solved by executing the segment creation in auto commit mode.

Actions

Also available in: Atom PDF