Project

General

Profile

Actions

Bug #879

closed

'FINISH_TIME' looks malformatted in filedetail.php

Added by Flix Josep about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Start date:
08/31/2010
Due date:
% Done:

100%

Estimated time:

Description

Hi,

to note that 'FINISH_TIME' looks malformatted. For example, for this fileid:

http://ftm.pic.es/ftsmonitor//filedetail.php?fileid=29187168

it seems the file transfer was finished by '20-AUG-10 07.34.33.000000 AM +00:00', which is wrong if one looks into the FTS log (attached).

Lionel comments the problem is on the database schema:

"It seems it's a bug in the database scheme:

SQL> describe fts2_prod.t_job;
Name Null? Type
----------------------------------------- -------- ----------------------------
FINISH_TIME TIMESTAMP WITH TIME ZONE
JOB_FINISHED TIMESTAMP

JOB_FINISHED misses the TZ so I guess the values your see in your pages are alright:

<FINISH_TIME>20-AUG-10 07.34.33.000000 AM +00:00</FINISH_TIME>
<JOB_FINISHED>20-AUG-10 09.34.36.612909 AM</JOB_FINISHED>
2010-08-20 09:34:31,853 [INFO ] - FINAL:SUCCESS

JOB_FINISHED is in UTC whereas JOB_FINISHED is in localtime."

Lionel, could you contact FTS developers so they use UTC times elsewhere?

Thanks,
Pepe.


Files

Actions #1

Updated by Schwarz Lionel about 11 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed in 1.5: all dates and times are displayed with the same format at same timezone, customized in the user config.
I have submitted a bug to FTS:
https://savannah.cern.ch/bugs/?71921

Actions

Also available in: Atom PDF