Project

General

Profile

Actions

Bug #5640

closed

Stacktrace

Added by Lavoisier Api over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
Stacktrace
Target version:
-
Start date:
12/11/2013
Due date:
% Done:

100%

Estimated time:

Description

enjoy !!!

fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'voms_vo' [Adaptor raised exception -- org.xml.sax.SAXException
java.lang.NullPointerException]
at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:26)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:101)
at fr.in2p3.lavoisier.chaining.Chain.writeToContentHandler(Chain.java:84)
at fr.in2p3.lavoisier.engine.view.ViewCached.writeToXMLEventHandler(ViewCached.java:87)
at fr.in2p3.lavoisier.xml.XmlView.write(XmlView.java:49)
at fr.in2p3.lavoisier.connector.XMLConnector.writeToContentHandler(XMLConnector.java:34)
at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:24)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:101)
at fr.in2p3.lavoisier.chaining.Chain.writeToCache(Chain.java:90)
at fr.in2p3.lavoisier.engine.view.ViewCached.refresh(ViewCached.java:116)
at fr.in2p3.lavoisier.engine.task.CacheRefreshTask.run(CacheRefreshTask.java:22)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)
Caused by: java.lang.NullPointerException

Actions #1

Updated by L'Orphelin Cyril over 8 years ago

jvm 1 | 11 déc. 2013 14:29:44 fr.in2p3.lavoisier.engine.view.ViewCached refresh
jvm 1 | ATTENTION: Failed to refresh cache for view: voms_users
jvm 1 | fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'voms_vo' [Adaptor raised exception -- org.xml.sax.SAXException
jvm 1 | java.lang.NullPointerException]
jvm 1 | at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:26)
jvm 1 | at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:101)
jvm 1 | at fr.in2p3.lavoisier.chaining.Chain.writeToContentHandler(Chain.java:84)
jvm 1 | at fr.in2p3.lavoisier.engine.view.ViewCached.writeToXMLEventHandler(ViewCached.java:87)
jvm 1 | at fr.in2p3.lavoisier.xml.XmlView.write(XmlView.java:49)
jvm 1 | at fr.in2p3.lavoisier.connector.XMLConnector.writeToContentHandler(XMLConnector.java:34)
jvm 1 | at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:24)
jvm 1 | at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:101)
jvm 1 | at fr.in2p3.lavoisier.chaining.Chain.writeToCache(Chain.java:90)
jvm 1 | at fr.in2p3.lavoisier.engine.view.ViewCached.refresh(ViewCached.java:116)
jvm 1 | at fr.in2p3.lavoisier.engine.task.CacheRefreshTask.run(CacheRefreshTask.java:22)
jvm 1 | at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
jvm 1 | at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
jvm 1 | at java.lang.Thread.run(Thread.java:701)
jvm 1 | Caused by: java.lang.NullPointerException
jvm 1 | at fr.in2p3.lavoisier.engine.ChainOfAdaptors.addProcessor(ChainOfAdaptors.java:58)
jvm 1 | at fr.in2p3.lavoisier.engine.view.PostProcessor.addProcessors(PostProcessor.java:30)
jvm 1 | at fr.in2p3.lavoisier.engine.view.ViewDirect.writeToXMLEventHandler(ViewDirect.java:38)
jvm 1 | at fr.in2p3.lavoisier.xml.XmlView.write(XmlView.java:49)
jvm 1 | at fr.in2p3.lavoisier.processor.main.InsertProcessor.insert(InsertProcessor.java:176)
jvm 1 | at fr.in2p3.lavoisier.processor.main.InsertProcessor.endElement(InsertProcessor.java:125)
jvm 1 | at fr.in2p3.lavoisier.chaining.link.processor.ProcessorWithExpressionLink.endElement(ProcessorWithExpressionLink.java:111)
jvm 1 | at fr.in2p3.lavoisier.xpath.absolute.engine.Dom4jWriter.dump(Dom4jWriter.java:104)
jvm 1 | at fr.in2p3.lavoisier.xpath.absolute.engine.Dom4jWriter.dump(Dom4jWriter.java:54)
jvm 1 | at fr.in2p3.lavoisier.xpath.absolute.XPathAbsolutePlan.playback(XPathAbsolutePlan.java:132)
jvm 1 | at fr.in2p3.lavoisier.xpath.XPathAbsoluteHandler.endElement(XPathAbsoluteHandler.java:116)
jvm 1 | at fr.in2p3.lavoisier.chaining.link.output.XmlToXmlOutputLink.endElement(XmlToXmlOutputLink.java:48)
jvm 1 | at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:607)
jvm 1 | at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1766)
jvm 1 | at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2926)
jvm 1 | at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:625)
jvm 1 | at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:117)
jvm 1 | at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:489)
jvm 1 | at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:828)
jvm 1 | at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:757)
jvm 1 | at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:133)
jvm 1 | at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1211)
jvm 1 | at fr.in2p3.lavoisier.connector.FileCacheConnector.writeToContentHandler(FileCacheConnector.java:52)
jvm 1 | at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:24)
jvm 1 | ... 13 more

Actions #2

Updated by Reynaud Sylvain over 8 years ago

  • Status changed from New to Resolved
  • Assigned To set to Reynaud Sylvain
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF