Project

General

Profile

Actions

Bug #9666

closed

Stacktrace

Added by Lavoisier Api about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
Stacktrace
Target version:
-
Start date:
04/13/2015
Due date:
% Done:

100%

Estimated time:

Description

Build Version: 2.1.2-SNAPSHOT
Build Date: Fri Feb 20 11:52:07 UTC 2015
Author: lavoisier
Description: Describe the context of the problem here...
Stack Trace: fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'VO_full' [Adaptor raised exception -- java.lang.NullPointerException]
at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:26)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:120)
at fr.in2p3.lavoisier.chaining.Chain.writeToContentHandler(Chain.java:103)
at fr.in2p3.lavoisier.engine.view.ViewCached.writeToXMLEventHandler(ViewCached.java:111)
at fr.in2p3.lavoisier.xml.XmlView.write(XmlView.java:54)
at fr.in2p3.lavoisier.connector.XMLConnector.writeToContentHandler(XMLConnector.java:34)
at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:24)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:120)
at fr.in2p3.lavoisier.chaining.Chain.writeToCache(Chain.java:109)
at fr.in2p3.lavoisier.engine.view.ViewCached.refresh(ViewCached.java:145)
at fr.in2p3.lavoisier.engine.task.CacheRefreshTask.run(CacheRefreshTask.java:22)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
at fr.in2p3.lavoisier.template.plan.create._CreateAttribute.create(_CreateAttribute.java:55)
at fr.in2p3.lavoisier.template.plan.create._CreateAttribute.createIfMatched(_CreateAttribute.java:46)
at fr.in2p3.lavoisier.template.plan.input._E.startElement(_E.java:306)
at fr.in2p3.lavoisier.template.context.RulesHandler.startElement(RulesHandler.java:60)
at fr.in2p3.lavoisier.template.context.RulesHandler.replay(RulesHandler.java:93)
at fr.in2p3.lavoisier.template.XMLTemplate.endElement(XMLTemplate.java:56)
at fr.in2p3.lavoisier.chaining.link.output.XmlToXmlOutputLink.endElement(XmlToXmlOutputLink.java:48)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:609)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1782)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2973)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:606)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:117)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
at fr.in2p3.lavoisier.connector.FileCacheConnector.writeToContentHandler(FileCacheConnector.java:59)
at fr.in2p3.lavoisier.chaining.link.connector.SAXConnectorLink.generate(SAXConnectorLink.java:24)
... 13 more

Actions #1

Updated by Reynaud Sylvain about 7 years ago

  • Status changed from New to Resolved
  • Assigned To set to Reynaud Sylvain
  • % Done changed from 0 to 100

New error message is:

No XPath is set for: _CreateAttribute

Actions

Also available in: Atom PDF