Project

General

Profile

Actions

Bug #6583

closed

CSVSerializer throws IndexOutOfBoundsException

Added by Lavoisier Api over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
Stacktrace
Target version:
-
Start date:
03/20/2014
Due date:
% Done:

100%

Estimated time:

Description

Describe the context of the problem here...

fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'storage_usage_test' [Adaptor raised exception -- java.lang.IndexOutOfBoundsException: Index: 7, Size: 7]
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:26)
at fr.in2p3.lavoisier.chaining.link.connector.InputStreamConnectorLink.generate(InputStreamConnectorLink.java:43)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:101)
at fr.in2p3.lavoisier.chaining.Chain.writeToOutputStream(Chain.java:68)
at fr.in2p3.lavoisier.engine.view.ViewDirect.writeToOutputStream(ViewDirect.java:61)
at fr.in2p3.lavoisier.engine.Engine.execute(Engine.java:105)
at fr.in2p3.lavoisier.service.resources.LavoisierHttpHandler.service(LavoisierHttpHandler.java:141)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpHandlerChain.service(HttpHandlerChain.java:196)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:770)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:551)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:531)
at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.IndexOutOfBoundsException: Index: 7, Size: 7
at java.util.ArrayList.rangeCheck(ArrayList.java:604)
at java.util.ArrayList.get(ArrayList.java:382)
at fr.in2p3.lavoisier.serializer.CSVSerializer.writeRow(CSVSerializer.java:104)
at fr.in2p3.lavoisier.serializer.CSVSerializer.writeLine(CSVSerializer.java:95)
at fr.in2p3.lavoisier.interfaces.serializer.abstracts.LineEventSerializerAbstract.write(LineEventSerializerAbstract.java:22)
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:24)
... 24 more

Actions #1

Updated by Reynaud Sylvain over 8 years ago

  • Subject changed from Stacktrace to CSVSerializer throws IndexOutOfBoundsException
  • Status changed from New to Resolved
  • Assigned To set to Reynaud Sylvain
  • % Done changed from 0 to 100
CSVSerializer now throws the following exceptions by default:
  • Row has unexpected column(s): XXX
  • Row is missing some column(s): XXX

Setting the parameter "strict" to "false" disables this checking and silently accept every rows (same behavior as Microsoft Excel).

Actions

Also available in: Atom PDF