Project

General

Profile

Actions

Feature #35277

closed

add a CronTrigger plugin

Added by Reynaud Sylvain almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assigned To:
Category:
Adaptors
Target version:
-
Start date:
10/23/2018
Due date:
% Done:

100%

Estimated time:
Actions #1

Updated by Reynaud Sylvain almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
Actions #2

Updated by Vernet Renaud almost 3 years ago

je n'arrive pas a faire fonctionner le plugin
voici un exemple de ce que je fais

<trigger type="CronTrigger">
<parameter name="expressions">5 * * * *</parameter>
</trigger>

Exception in thread "main" fr.in2p3.lavoisier.interfaces.error.ConfigurationException: fr.in2p3.lavoisier.interfaces.error.InitializationException: Exception raised for view 'UsersJobEfficiency' [java.text.ParseException: Unexpected end of expression.]
at fr.in2p3.lavoisier.engine.view.TriggerFactory.<init>(TriggerFactory.java:42)
at fr.in2p3.lavoisier.engine.view.ViewCached.startTriggers(ViewCached.java:78)
at fr.in2p3.lavoisier.engine.view.ViewAbstract.create(ViewAbstract.java:55)
at fr.in2p3.lavoisier.engine.ContainerRegistry.<init>(ContainerRegistry.java:74)
at fr.in2p3.lavoisier.engine.Engine.init(Engine.java:74)
at fr.in2p3.lavoisier.engine.Engine.createInstance(Engine.java:55)
at fr.in2p3.lavoisier.command.StartServer.main(StartServer.java:39)
Caused by: fr.in2p3.lavoisier.interfaces.error.InitializationException: Exception raised for view 'UsersJobEfficiency' [java.text.ParseException: Unexpected end of expression.]
at fr.in2p3.lavoisier.chaining.AdaptorConfigurator.getConfiguredAdaptor(AdaptorConfigurator.java:42)
at fr.in2p3.lavoisier.engine.view.TriggerFactory.<init>(TriggerFactory.java:39)
... 6 more
Caused by: java.text.ParseException: Unexpected end of expression.
at org.quartz.CronExpression.buildExpression(CronExpression.java:494)
at org.quartz.CronExpression.<init>(CronExpression.java:276)
at fr.in2p3.lavoisier.trigger.CronTrigger.init(CronTrigger.java:40)
at fr.in2p3.lavoisier.chaining.AdaptorConfigurator.getConfiguredAdaptor(AdaptorConfigurator.java:34)
... 7 more

J'ai essaye de mettre le contenu de la balise entre guillemets, ca ne marche pas non plus.
Tu aurais un exemple d'utilisation ?
Merci

Actions #3

Updated by Reynaud Sylvain almost 3 years ago

J'ai modifié le plugin pour qu'il prenne 5 champs (comme crontab) au lieu de 6 (comme l'API sur laquelle il s'appuie).

J'attire ton attention sur 2 points:
  1. Mettre '*' sur le dernier champ déclenche une erreur "Support for specifying both a day-of-week AND a day-of-month parameter is not implemented.", il faut donc mettre '?' à la place.
  2. Bien que ça fonctionne également avec une simple chaîne de caractères grâce aux conversions implicites, il est préférable d'être conscient que le paramètre "expressions" attend une liste.

Exemple:

<parameter name="expressions">
    <entry>5 * * * ?</entry>
</parameter>

Actions

Also available in: Atom PDF