Project

General

Profile

Actions

Support #17355

closed

Synchronisation demandée pour un serveur Mercurial

Added by Lafage Vincent about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Start date:
03/26/2017
Due date:
% Done:

0%

Estimated time:

Description

Bonjour,

je souhaiterais connecter un dépôt Mercurial à la Forge.
Voici ses références
hg clone https://ipnvcs.in2p3.fr/hg/electron_capture
Cela doit reprendre les mêmes éléments que le ticket
https://forge.in2p3.fr/issues/14859
notamment l'utilisateur forgeadmin

(cela concernait le projet https://forge.in2p3.fr/projects/c3f2
mais désormais cela concerne https://forge.in2p3.fr/projects/electroncapture)

Je souhaite également pouvoir connecter les deux dépôts suivants
hg clone https://ipnvcs.in2p3.fr/hg/Dispatching
hg clone https://ipnvcs.in2p3.fr/hg/CommonIncludes
Je poserai une continuation à ce ticket pour deux autres dépôts que je mets au point actuellement

Je suis disponible pour tout éclaircissement

À+
Vincent

Actions #1

Updated by Lafage Vincent about 5 years ago

je souhaiterais également connecter ces deux dépôts Mercurial à la Forge :
https://ipnvcs.in2p3.fr/hg/daq-MCH-ECS
https://ipnvcs.in2p3.fr/hg/LC2
Voilà.
Ce ticket est complet.

Actions #2

Updated by Brétel Foudil about 5 years ago

  • Status changed from New to Closed

Bonjour Vincent,

J'ai synchronisé les dépôts mentionnés. Tu pourras donc les ajouter aux projets correspondants, comme je l'ai fait avec le projet electroncapture, en déclarant dans la configuration:

SCM: Mercurial
Chemin du dépôt: /sites/forge/www/hg_repositories/<DEPOT>.hg

à bientôt

Actions #3

Updated by Lafage Vincent about 5 years ago

Merci !
Ça fonctionne du tonnerre !
À+
Vincent

Actions #4

Updated by Lafage Vincent about 5 years ago

J'ai un petit problème : après quelques push, bien espacés dans le temps, je ne vois toujours pas la forge se synchroniser sur les dépôts (alors qu'avec C3F2, nous y arrivons bien cf
https://forge.in2p3.fr/projects/c3f2/repository)

Est-ce que j'ai oublié de faire quelques chose ?
Est-ce que les log nous renseignent ?

À+
Vincent

Actions #5

Updated by Brétel Foudil about 5 years ago

Effectivement, les identifiants HTTP n'étaient pas sauvegardés :(
Je viens de corriger. Ça a l'air de bien passer.
à bientôt

Actions #6

Updated by Lafage Vincent about 5 years ago

Merci !

Ça marche.

À+

Actions

Also available in: Atom PDF