Project

General

Profile

Actions

Bug #16577

closed

Stacktrace

Added by Lavoisier Api over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
Stacktrace
Target version:
-
Start date:
01/05/2017
Due date:
% Done:

100%

Estimated time:

Description

Build Version: 2.1.2-SNAPSHOT
Build Date: Wed Jan 04 10:25:04 UTC 2017
Author: cyril
Description: fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'VO_CPU' [Adaptor raised exception -- java.lang.NullPointerException]
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:26)
at fr.in2p3.lavoisier.chaining.link.connector.InputStreamConnectorLink.generate(InputStreamConnectorLink.java:43)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:120)
at fr.in2p3.lavoisier.chaining.Chain.writeToOutputStream(Chain.java:87)
at fr.in2p3.lavoisier.engine.view.ViewDirect.writeToOutputStream(ViewDirect.java:62)
at fr.in2p3.lavoisier.engine.Engine.execute(Engine.java:149)
at fr.in2p3.lavoisier.service.resources.LavoisierHttpHandler.service(LavoisierHttpHandler.java:265)
at fr.in2p3.lavoisier.service.resources.AbstractHttpHandler.service(AbstractHttpHandler.java:39)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpHandlerChain.service(HttpHandlerChain.java:196)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:770)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:551)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:531)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
at fr.in2p3.lavoisier.adaptor.JSONStreamSerializer.write(JSONStreamSerializer.java:52)
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:24)
... 25 more

et la vue :

<view name="VO_CPU" xmlns:date="http://exslt.org/dates-and-times">
<info>
<category>VO</category>
<description>Retrieve the CPU consumption from acc portal</description>
</info>
<argument name="dateN" eval="substring(date:date(),0,11)"></argument>
<connector type="HTTPConnector">
<parameter name="url">https://accounting-support.egi.eu/custom_cloud.php?query=sum_cpu
Stack Trace: fr.in2p3.lavoisier.interfaces.error.AdaptorException: Exception raised for view 'VO_CPU' [Adaptor raised exception -- java.lang.NullPointerException]
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:26)
at fr.in2p3.lavoisier.chaining.link.connector.InputStreamConnectorLink.generate(InputStreamConnectorLink.java:43)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:120)
at fr.in2p3.lavoisier.chaining.Chain.writeToOutputStream(Chain.java:87)
at fr.in2p3.lavoisier.engine.view.ViewDirect.writeToOutputStream(ViewDirect.java:62)
at fr.in2p3.lavoisier.engine.Engine.execute(Engine.java:149)
at fr.in2p3.lavoisier.service.resources.LavoisierHttpHandler.service(LavoisierHttpHandler.java:265)
at fr.in2p3.lavoisier.service.resources.AbstractHttpHandler.service(AbstractHttpHandler.java:39)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpHandlerChain.service(HttpHandlerChain.java:196)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:770)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:551)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:531)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
at fr.in2p3.lavoisier.adaptor.JSONStreamSerializer.write(JSONStreamSerializer.java:52)
at fr.in2p3.lavoisier.chaining.link.serializer.Stream2XmlSerializerLink.generate(Stream2XmlSerializerLink.java:24)
... 25 more
Actions #1

Updated by Reynaud Sylvain over 5 years ago

  • Status changed from New to Resolved
  • Assigned To set to Reynaud Sylvain
  • % Done changed from 0 to 100

bug fixed in module lavoisier-serializer-json

Actions

Also available in: Atom PDF