Project

General

Profile

Actions

Bug #10686

closed

Stacktrace

Added by Lavoisier Api almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Low
Assigned To:
Category:
XML Template Engine
Target version:
Start date:
08/19/2015
Due date:
% Done:

100%

Estimated time:

Description

Build Version: 2.1.2-SNAPSHOT
Build Date: Thu Jun 04 07:36:19 UTC 2015
Author: cyril
Description: Describe the context of the problem here...
Stack Trace: fr.in2p3.lavoisier.interfaces.error.ConversionException: Exception raised for view 'OPSCORE_osg_sites' [java.lang.NullPointerException]
at fr.in2p3.lavoisier.chaining.link.connector.InputStreamConnectorLink.generate(InputStreamConnectorLink.java:51)
at fr.in2p3.lavoisier.chaining.Chain.generate(Chain.java:120)
at fr.in2p3.lavoisier.chaining.Chain.writeToOutputStream(Chain.java:87)
at fr.in2p3.lavoisier.engine.view.ViewDirect.writeToOutputStream(ViewDirect.java:62)
at fr.in2p3.lavoisier.engine.Engine.execute(Engine.java:132)
at fr.in2p3.lavoisier.service.resources.LavoisierHttpHandler.service(LavoisierHttpHandler.java:256)
at fr.in2p3.lavoisier.service.resources.AbstractHttpHandler.service(AbstractHttpHandler.java:39)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpHandlerChain.service(HttpHandlerChain.java:196)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:175)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:770)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:551)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:531)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
at fr.in2p3.lavoisier.template.context.Input.comment(Input.java:123)
at fr.in2p3.lavoisier.template.XMLTemplate.comment(XMLTemplate.java:74)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.comment(AbstractSAXParser.java:675)
at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.comment(XMLDTDValidator.java:956)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:478)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:848)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:777)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
at fr.in2p3.lavoisier.chaining.link.connector.InputStreamConnectorLink.generate(InputStreamConnectorLink.java:49)
... 24 more

Actions #1

Updated by Reynaud Sylvain almost 7 years ago

  • Category changed from Stacktrace to XML Template Engine
  • Status changed from New to Resolved
  • Assigned To set to Reynaud Sylvain
  • Target version set to 2.1.2
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF