Suppression des modules externes

Les modules externes suivants peuvent être supprimés:
  • jce-jdk13:
    1. cog-globus et wsgram-api: remplacé par bcprov-jdk13
    2. glite-ce-cream-api-java: remplacé par bcprov-jdk14 (puisque ce module utilisait déjà bcpg-jdk14 -> passage en 1.46)
  • xmlsec:
    1. wsgram-api: remplacé par la version standard 1.4.5 (comme l'API Unicore)
  • ganymed-ssh2:
    1. batchssh: remplacé par la version standard build260
    2. SSH2: A FAIRE
  • jsch:
    1. ssh: remplacé par la version standard 0.1.45
  • jzlib:
    1. ssh: remplacé par la version standard 1.0.7
Les modules suivants ne sont pas supprimés:
  • cryptix32:
    1. cog-globus: l'exécution du globus init avec le module cryptix32 standard donne:
      NoSuccess: Proxy verification failed
      Caused by: org.globus.gsi.GlobusCredentialException: [JGLOBUS-116] Certificate validation failed. [Caused by:  [Caused by: java.security.NoSuchAlgorithmException: no such algorithm: SHA-1/RSA/PKCS#1 for provider Cryptix]]
          at org.globus.gsi.GlobusCredential.verify(GlobusCredential.java:333)
          at fr.in2p3.jsaga.adaptor.security.GlobusProxyFactory.createProxy(GlobusProxyFactory.java:118)
      

      Note: les modules puretls, cryptix-asn1 et cryptix32 disparaissent avec jglobus-2
  • concurrent:
    1. wsgram-api: le portage vers les classes standard java.util.concurrent nécessite des modifications de code
  • commonj:
    1. wsgram-api: erreur de compilation
  • opensaml:
    1. wsgram-api: version 3.9 et 4.0.0 introuvables. Plusieurs repositories existent pour opensaml-2.
      Comme ce module n'est utilisé que par wsgram-api, on laisse tel quel
  • cryptix-asn1, jargon, jeldoclet, puretls, cog-axis, cog-url, classad
    pas de repository Maven standard
  • addressing:
    1. wsgram-api: utilise la version 1.0 ainsi que wsrf-tools et wsrf-core

Pour l'utilisation du module 1.0, remplacement par la version OW2 (repository qui semble obsolète)
http://maven.ow2.org/maven2/org/apache/axis/addressing/1.0/

Erreur de compilation:
jsaga/externals/wsgram-api/wsrf-core/java/org/globus/wsrf/impl/security/authentication/wssec/WSSecurityEngine.java:[438,51] cannot find symbol
symbol : variable NS_URI_ADDRESSING
location: class org.apache.axis.message.addressing.Constants