Bug #6020

[gsiftp] Unknown object id -EMAIL - passed to distinguished name

Added by Schwarz Lionel almost 7 years ago. Updated almost 7 years ago.

Status:ResolvedStart date:02/06/2014
Priority:HighDue date:
Assigned To:Schwarz Lionel% Done:

0%

Category:Globus adaptors
Target version:1.0.1

Description

Exception at GridFTP connection on ce01.tier2.hep.manchester.ac.uk:

AuthenticationFailed: GSSException: Invalid name provided [Caused by: Unknown object id - EMAIL - passed to distinguished name]
    at fr.in2p3.jsaga.adaptor.data.GsiftpDataAdaptorAbstract.createConnection(GsiftpDataAdaptorAbstract.java:364)
    at fr.in2p3.jsaga.adaptor.data.GsiftpDataAdaptorAbstract.connect(GsiftpDataAdaptorAbstract.java:83)
    at fr.in2p3.jsaga.adaptor.data.GsiftpDataAdaptor.connect(GsiftpDataAdaptor.java:66)
    at fr.in2p3.jsaga.engine.factories.DataAdaptorFactory.getDataAdaptorAndConnect(DataAdaptorFactory.java:106)
    at fr.in2p3.jsaga.impl.namespace.AbstractSyncNSFactoryImpl.doCreateNSDirectorySync(AbstractSyncNSFactoryImpl.java:61)
    at fr.in2p3.jsaga.impl.namespace.NSFactoryImpl.doCreateNSDirectory(NSFactoryImpl.java:48)
    at org.ogf.saga.namespace.NSFactory.createNSDirectory(NSFactory.java:667)
    at org.ogf.saga.namespace.NSFactory.createNSDirectory(NSFactory.java:606)
    at org.ogf.saga.namespace.IntegrationClean.setUp(IntegrationClean.java:27)
    at junit.framework.TestCase.runBare(TestCase.java:139)
    at junit.framework.TestResult$1.protect(TestResult.java:122)
    at junit.framework.TestResult.runProtected(TestResult.java:142)
    at junit.framework.TestResult.run(TestResult.java:125)
    at junit.framework.TestCase.run(TestCase.java:129)
    at junit.framework.TestSuite.runTest(TestSuite.java:255)
    at junit.framework.TestSuite.run(TestSuite.java:250)
    at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:84)
    at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
    at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
    at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)
Caused by: GSSException: Invalid name provided [Caused by: Unknown object id - EMAIL - passed to distinguished name]
    at org.globus.gsi.gssapi.GlobusGSSContextImpl.initSecContext(GlobusGSSContextImpl.java:1096)
    at org.globus.ftp.extended.GridFTPControlChannel.authenticate(GridFTPControlChannel.java:209)
    at org.globus.ftp.GridFTPClient.authenticate(GridFTPClient.java:127)
    at org.globus.ftp.GridFTPClient.authenticate(GridFTPClient.java:103)
    at fr.in2p3.jsaga.adaptor.data.GsiftpDataAdaptorAbstract.createConnection(GsiftpDataAdaptorAbstract.java:342)
    ... 22 more
Caused by: GSSException: Invalid name provided [Caused by: Unknown object id - EMAIL - passed to distinguished name]
    at org.globus.gsi.gssapi.GlobusGSSName.<init>(GlobusGSSName.java:170)
    at org.globus.gsi.gssapi.GlobusGSSContextImpl.initSecContext(GlobusGSSContextImpl.java:1050)
    ... 26 more
Caused by: java.lang.IllegalArgumentException: Unknown object id - EMAIL - passed to distinguished name
    at org.bouncycastle.asn1.x500.style.IETFUtils.decodeAttrName(Unknown Source)
    at org.globus.gsi.bc.GlobusStyle.attrNameToOID(GlobusStyle.java:245)
    at org.globus.gsi.bc.GlobusStyle.fromString(GlobusStyle.java:154)
    at org.bouncycastle.asn1.x500.X500Name.<init>(Unknown Source)
    at org.globus.gsi.util.CertificateUtil.toPrincipal(CertificateUtil.java:602)
    at org.globus.gsi.gssapi.GlobusGSSName.<init>(GlobusGSSName.java:168)
    ... 27 more

History

#3 Updated by Schwarz Lionel almost 7 years ago

  • Status changed from New to In progress

#5 Updated by Schwarz Lionel almost 7 years ago

  • Status changed from In progress to Resolved

Also available in: Atom PDF