Project

General

Profile

Actions

Feature #3432

closed

JSAGA + UNICORE: authentication failed

Added by Carpené Michele over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
Category:
Unicore adaptors
Target version:
-
Start date:
11/15/2012
Due date:
% Done:

0%

Estimated time:

Description

Hi Lionel,
thanks a lot, now I've configured the xml file as it is:


<jsaga-default xmlns="http://www.in2p3.fr/jsaga/session">
<contexts>
<context type="VOMS">
<data type="gsiftp"/>
<data type="srm"/>
<data type="lfn"/>
<job type="wms"/>
<job type="cream"/>
</context>
<context type="JKS">
<data type="unicore"/>
<job type="unicore"/>
</context>
</contexts>
<session>
<context type="JKS">
<attribute name="Keystore" value="/home/mcarpene/Scrivania/VERCE/JSAGA/bin/mykeystore.jks"/>
<attribute name="KeystorePass" value="Tomyork198198"/>
<attribute name="Truststore" value="/home/mcarpene/Scrivania/Certificati/keystore.jks"/>
<attribute name="TruststorePass" value="storepass"/>
</context>
</session>
</jsaga-default>

and remove jvm properties, now the error has changed:

/Scrivania/VERCE/JSAGA/bin$./jsaga-job-run.sh -b -Executable /bin/hostname -r unicore://grid.cineca.it:9111/Target?=CINECA-PLX -Output output.txt -Error error.txt
Exception in thread "main" java.lang.NoClassDefFoundError
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.class$(DefaultTypeMappingRegistry.java:64)
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.createDefaultMappings(DefaultTypeMappingRegistry.java:406)
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.createDefaultMappings(DefaultTypeMappingRegistry.java:311)
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.<init>(DefaultTypeMappingRegistry.java:131)
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.<init>(DefaultTypeMappingRegistry.java:137)
at org.codehaus.xfire.aegis.type.DefaultTypeMappingRegistry.<init>(DefaultTypeMappingRegistry.java:118)
at org.codehaus.xfire.xmlbeans.XmlBeansTypeRegistry.<init>(XmlBeansTypeRegistry.java:11)
at org.codehaus.xfire.xmlbeans.XmlBeansServiceFactory.<init>(XmlBeansServiceFactory.java:17)
at eu.unicore.security.xfireutil.client.JSR181ServiceFactory.<init>(JSR181ServiceFactory.java:63)
at eu.unicore.security.xfireutil.client.SecuredXFireClientFactory.<init>(SecuredXFireClientFactory.java:92)
at de.fzj.unicore.wsrflite.xfire.WSRFClientFactory.<init>(WSRFClientFactory.java:62)
at de.fzj.unicore.wsrflite.xmlbeans.client.BaseWSRFClient.<init>(BaseWSRFClient.java:158)
at de.fzj.unicore.uas.client.BaseUASClient.<init>(BaseUASClient.java:68)
at de.fzj.unicore.uas.client.TSFClient.<init>(TSFClient.java:32)
at fr.in2p3.jsaga.adaptor.unicore.job.UnicoreJobControlAdaptor.connect(UnicoreJobControlAdaptor.java:81)
at fr.in2p3.jsaga.engine.factories.JobAdaptorFactory.connect(JobAdaptorFactory.java:66)
at fr.in2p3.jsaga.engine.factories.JobAdaptorFactory.connect(JobAdaptorFactory.java:61)
at fr.in2p3.jsaga.impl.job.AbstractSyncJobFactoryImpl.doCreateJobServiceSync(AbstractSyncJobFactoryImpl.java:72)
at fr.in2p3.jsaga.impl.job.JobFactoryImpl.doCreateJobService(JobFactoryImpl.java:35)
at org.ogf.saga.job.JobFactory.createJobService(JobFactory.java:202)
at org.ogf.saga.job.JobFactory.createJobService(JobFactory.java:146)
at fr.in2p3.jsaga.command.JobRun.main(JobRun.java:77)
Caused by: java.lang.ClassNotFoundException: org.jdom.Element
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:186)
... 22 more

PS: I cannot update the ticket or answer, I think I've no permission :(

BR,
Michele

Actions #1

Updated by Schwarz Lionel over 8 years ago

  • Description updated (diff)
  • Status changed from Assigned to Closed

It should be OK now for you to modify ticket https://forge.in2p3.fr/issues/3430. I'm closing this one.
Thanks
Lionel

Actions

Also available in: Atom PDF